Home Forums TECHNICZNE Działanie robota Podczas pracy robota włącza mi się wygaszacz ekranu

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2959
    JurekN
    Participant

    System Windows nie zawsze odbiera to co robi robot w aplikacjach jako prace człowieka co powoduje po upłynięciu czasu X włączenie się wygaszacza ekranu.
    W związku z powyższym, niektóre z akcji które opierają się na huntach graficznych lub na akcjach „Send keystrokes” nie wykonają się poprawnie i scenariusz się przerwie. Co zrobić?

    #2960
    mciurzynska
    Keymaster

    Robot na stacji roboczej jest specyficznym użytkownikiem ( uprawnienia https://wizlink.eu/forums/topic/uprawnienia-dla-robota/) i nie każda akcja wykonywana przez robota jest faktycznie odczytywana jako praca człowiek w windowsie. Zalecamy, aby Środowisko pracy dla robota nie miało ustawionego blokowania się w wyniku bierności użytkownika.
    Natomiast można „oszukać” windows wykonując robotem aktywności ( uruchamijać programy ), które windows odczyta jako aktywność użytkownika np. odpalenie za pomoca aktywności Run Application CMD i zamknięcie go co X jednotki czasu, tak by wygaszacz się nie włączył.

    Załączam scenariusz testowy:
    1. Proszę otworzyć go w designerze
    2. Na pulpicie umieścić pustego excela
    3. Po kliknięciu w Variables( w dolnym lewym rogu flowcharta) proszę zmienić ścieżkę do excela (excelPath) oraz ścieżkę do CMD( aczkolwiek jest raczej uniwersalna).

    Robot z założenia otworzy excela którego Pan wskaże i zacznie wprowadzać liczby od 1 do 1000000 co 9 sekund, jeśli ten czas nie wystarczy na włączenie się blokady proszę zwiększyć ilość sekund w zmiennej delay ( teraz są tam 3 sekundy).
    Robot odpala CMD i wprowadza do niego komendę „EXIT”, zamyka CMD. Uruchomienie CMD powoduje na mojej maszynie brak problemu z potencjalnym wygaszaczem i blokadą może i u Państwa się sprawdzi.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.