Home Forums TWORZENIE SCENARIUSZA Send Single Mail

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3049
    JanOrzechowski
    Participant

    Próbuję wysłać plik z załącznikami mailem, ale aktywność wisi. Nie dałem Timeoutu na żadną wartość, aktywność nie sypie błędem, ale to trwa zdecydowanie za długo i nie mam pomysłu dlaczego, czy ktoś może mi podpowiedzieć, czego mi brakuje lub gdzie mam błąd?

    #3052
    mciurzynska
    Keymaster

    Proszę wrzucić log z Wizlinka z takiej jednej próby wykonania tej aktywności. Logi są w plikach txt w ścieżce: C:\Users\USERNAME\AppData\Local\WizLink\logs

    #3053
    JanOrzechowski
    Participant

    Proszę, wyczyściłem logi przed wykonaniem Send Mail

    #3057
    Tomasz Górecki
    Keymaster

    Brak łączności z serwerem może wynikać z różnych przyczyn. Często jest to kwestia ustawień na koncie, które jest wykorzystywane.
    Odnośnie Pańskich załączników:
    1. Proszę zwrócić uwagę na konfigurację, której Pan użył w aktywności Send Single Email. Port dla gmail to 465/587 w zależności od SSL/TLS. Port 993 to port dla serwera poczty przychodzącej.
    2. Domyślny Timeout to 60s. W testach najlepiej jest skrócić ten parametr np. do 10s. a także skorzystać z parametru Result na aktywności (proszę pamiętać o odznaczeniu checkboxu “Alternative Scenario If Failed” w aktywności) i po aktywności wyświetlić wartość tego parametru.
    3. Gmail wymaga dodatkowej konfiguracji:
    -w koncie powinno być włączone przekazywanie POP/IMAP/SMTP w zależności od użycia (dok. do POP https://support.google.com/mail/answer/7104828?hl=pl&visit_id=637220277114373627-4051974991&rd=3)
    -także ten parametr powinien być włączony: https://myaccount.google.com/lesssecureapps?pli=1

    BTW.
    Np. konta na serwerach wp.pl tez powinny być skonfigurowane – w opcjach (zakładka na górze po zalogowaniu) powinny być włączone parametry Dostęp przez POP3 oraz SMTP.

    #3082
    mciurzynska
    Keymaster

    Razem z Panem Janem sprawdziliśmy kilka opcji:
    1. Pan Jan napisała skrypt w PowerShell, aby sprawdzić czy można wysyłać maile, porty nie są blokowane dla użytkownika i tu próba się powiodła.
    2. Przy tych samych ustawieniach w Wizlinku – mail nie wychodził z informacją o problemie z autentykacją oraz certyfikatem.

    Ostatecznie okazało się, że antywirus (AVG) blokował możliwość wysłania maila Wizlinkiem z serwera.
    Uwaga: W tym przypadku AVG nie informuje o tym, że blokuje Wizlinka.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.